Portal login delays

Resolved Major
March 5, 2026 at 9:15 AM Lasted 2h 15m

Affected

PortalID

Updates

Resolved March 5, 2026 at 11:30 AM

Login performance has returned to normal. The underlying database connection pool has been tuned to prevent recurrence.

Monitoring March 5, 2026 at 10:45 AM

A fix has been deployed. Login times are improving. We are monitoring for stability.

Identified March 5, 2026 at 9:45 AM

Root cause identified: database connection pool exhaustion during peak morning traffic.

Investigating March 5, 2026 at 9:15 AM

We are investigating reports of slow login times on the Portal.

Show incident history